Revert "No deps by default on local install"

This reverts commit 751ddeea.
10 jobs from master in 3 minutes and 26 seconds (queued for 3 seconds)
Status Job ID Name Coverage
  Build
passed #13947
build:2.7

00:00:47

passed #13948
build:3

00:00:47

 
  Test
failed #13950
allowed to fail
lint:2.7

00:00:41

failed #13953
allowed to fail
lint:3

00:00:50

passed #13949
pyflakes:2.7

00:00:55

failed #13952
pyflakes:3

00:00:46

failed #13951
unittests:2.7

00:00:45

failed #13954
unittests:3

00:00:46

 
  Deploy
skipped #13955
doc:2.7
skipped #13956
doc:3
 
Name Stage Failure
failed
lint:3 Test
2019-01-02 18:59:00,775:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module voyagessncf: [ImportError] This module isn't compatible with python3
2019-01-02 18:59:00,781:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module wellsfargo: [ModuleNotFoundError] No module named 'Cookie'
2019-01-02 18:59:00,805:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module youtube: [ImportError] Please install python-googleapi
2019-01-02 18:59:00,808:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module zerobin: [ModuleNotFoundError] No module named 'Cryptodome'
=== [ 0%] Getting file:///builds/weboob/weboob/modules
=== [100%] All modules are up-to-date.
Errors building modules: apivie, arretsurimages, attilasub, bouygues, canaltp, cappedtv, chronopost, dailymotion, dlfp, ehentai, europarl, fourchan, gazelle, gdcvault, gdfsuez, genericnewspaper, geolocip, happn, hds, ilmatieteenlaitos, izneo, jacquieetmichel, jvmalin, lacentrale, leclercmobile, lefigaro, liberation, nettokom, newsfeed, nihonnooto, opacwebaloes, phpbb, presseurop, sfr, tapatalk, trictractv, unsee, ups, voyagessncf, wellsfargo, youtube, zerobin
Use --debug to get more information.
ERROR: Job failed: exit code 1
failed
lint:2.7 Test
2019-01-02 18:57:15,539:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module phpbb: [ImportError] Please install python-feedparser
2019-01-02 18:57:15,568:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module presseurop: [ImportError] Please install python-feedparser
2019-01-02 18:57:15,853:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module youtube: [ImportError] Please install python-googleapi
2019-01-02 18:57:15,858:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module zerobin: [ImportError] No module named Cryptodome.Cipher
Errors building modules: genericnewspaper, presseurop, bouygues, dlfp, happn, youtube, liberation, zerobin, newsfeed, phpbb, lefigaro
Use --debug to get more information.
=== [ 0%] Getting file:///builds/weboob/weboob/modules
=== [100%] All modules are up-to-date.
ERROR: Job failed: exit code 1
failed
unittests:2.7 Test
2019-01-02 18:58:02,962:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module phpbb: [ImportError] Please install python-feedparser
2019-01-02 18:58:02,981:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module presseurop: [ImportError] Please install python-feedparser
2019-01-02 18:58:03,137:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module youtube: [ImportError] Please install python-googleapi
2019-01-02 18:58:03,139:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module zerobin: [ImportError] No module named Cryptodome.Cipher
Errors building modules: genericnewspaper, presseurop, bouygues, dlfp, happn, youtube, liberation, zerobin, newsfeed, phpbb, lefigaro
Use --debug to get more information.
=== [ 0%] Getting file:///builds/weboob/weboob/modules
=== [100%] All modules are up-to-date.
ERROR: Job failed: exit code 1
failed
pyflakes:3 Test
  Stored in directory: /root/.cache/pip/wheels/5d/1a/1e/0350bb3df3e74215cd91325344cc86c2c691f5306eb4d22c77
Successfully built simplejson
Installing collected packages: simplejson
Successfully installed simplejson-3.16.0
$ ./tools/pyflakes.sh -3
/usr/local/lib/python3.7/site-packages/pycodestyle.py:113: FutureWarning: Possible nested set at position 1
EXTRANEOUS_WHITESPACE_REGEX = re.compile(r'[[({] | []}),;:]')
modules/arte/pages.py:64:34: F821 undefined name 'basestring'
ERROR: Job failed: exit code 1
failed
unittests:3 Test
2019-01-02 18:59:04,423:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module voyagessncf: [ImportError] This module isn't compatible with python3
2019-01-02 18:59:04,431:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module wellsfargo: [ModuleNotFoundError] No module named 'Cookie'
2019-01-02 18:59:04,452:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module youtube: [ImportError] Please install python-googleapi
2019-01-02 18:59:04,455:WARNING:repository:1.4:repositories.py:304:build_index Unable to build module zerobin: [ModuleNotFoundError] No module named 'Cryptodome'
=== [ 0%] Getting file:///builds/weboob/weboob/modules
=== [100%] All modules are up-to-date.
Errors building modules: apivie, arretsurimages, attilasub, bouygues, canaltp, cappedtv, chronopost, dailymotion, dlfp, ehentai, europarl, fourchan, gazelle, gdcvault, gdfsuez, genericnewspaper, geolocip, happn, hds, ilmatieteenlaitos, izneo, jacquieetmichel, jvmalin, lacentrale, leclercmobile, lefigaro, liberation, nettokom, newsfeed, nihonnooto, opacwebaloes, phpbb, presseurop, sfr, tapatalk, trictractv, unsee, ups, voyagessncf, wellsfargo, youtube, zerobin
Use --debug to get more information.
ERROR: Job failed: exit code 1