Commit f2caa3b0 authored by Laurent Bachelier's avatar Laurent Bachelier 🐧

setup.py: Add a command to get the requirements

--requires is not it; see
https://mail.python.org/pipermail/distutils-sig/2013-December/023180.html

This should help end-users to install weboob on their systems.
parent 1bb419cc
......@@ -156,6 +156,13 @@ def install_weboob():
if not options.deps:
requirements = []
try:
if sys.argv[1] == 'requirements':
print('\n'.join(requirements))
sys.exit(0)
except IndexError:
pass
setup(
name='weboob',
version='1.2',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment