Commit 901e148b authored by Vincent A's avatar Vincent A

python3: setup.py now requires python3.5 or higher

parent 8bf03a62
...@@ -152,7 +152,6 @@ def install_weboob(qt, xdg): ...@@ -152,7 +152,6 @@ def install_weboob(qt, xdg):
'six', 'six',
'unidecode', 'unidecode',
'Pillow', 'Pillow',
'futures; python_version < "3.2"',
'Babel', 'Babel',
] ]
...@@ -179,12 +178,11 @@ def install_weboob(qt, xdg): ...@@ -179,12 +178,11 @@ def install_weboob(qt, xdg):
'Environment :: X11 Applications :: Qt', 'Environment :: X11 Applications :: Qt',
'License :: OSI Approved :: GNU Lesser General Public License v3 or later (LGPLv3+)', 'License :: OSI Approved :: GNU Lesser General Public License v3 or later (LGPLv3+)',
'Programming Language :: Python', 'Programming Language :: Python',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3', 'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.5', 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6', 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7', 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python', 'Programming Language :: Python',
'Topic :: Communications :: Email', 'Topic :: Communications :: Email',
'Topic :: Internet :: WWW/HTTP', 'Topic :: Internet :: WWW/HTTP',
...@@ -199,7 +197,7 @@ def install_weboob(qt, xdg): ...@@ -199,7 +197,7 @@ def install_weboob(qt, xdg):
data_files=data_files, data_files=data_files,
install_requires=requirements, install_requires=requirements,
python_requires='>=2.7', python_requires='>=3.5',
tests_require=[ tests_require=[
'flake8', 'flake8',
'nose', 'nose',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment