Commit 78f6c847 authored by Vincent A's avatar Vincent A

setup.py: declare dependencies with dedicated setuptools syntax

parent f12f68a6
......@@ -135,6 +135,8 @@ def install_weboob():
'html2text>=3.200',
'six',
'unidecode',
'mechanize; python_version < "3.0"',
'futures; python_version < "3.2"',
]
try:
import Image
......@@ -147,16 +149,6 @@ def install_weboob():
else:
requirements.append('PIL')
if sys.version_info < (3, 0):
requirements.append('mechanize')
if sys.version_info < (3, 2):
requirements.append('futures')
if sys.version_info < (2, 7):
print('Python older than 2.7 is not supported.', file=sys.stderr)
sys.exit(1)
if not options.deps:
requirements = []
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment