Commit 121889dd authored by Phyks (Lucas Verney)'s avatar Phyks (Lucas Verney) Committed by Florent Fourcot

Basic update of CI to use Python 3 as well

parent d680bcdb
Pipeline #695 failed
coverage==4.2
flake8==3.2.1
future==0.16.0
mock==2.0.0
nose==1.3.7
pyflakes==1.3.0
six==1.10.0
xunitparser==1.3.3
image: "python:2.7"
before_script:
- "pip install -r .ci/requirements.txt"
- "REQUIREMENTS=$(mktemp) && python setup.py requirements > ${REQUIREMENTS} && pip install -r ${REQUIREMENTS} && rm ${REQUIREMENTS}"
- "pip install -r .ci/requirements_modules.txt"
build:
stage: "build"
script:
- "./tools/local_install.sh ~/bin"
lint:
stage: "test"
script:
- "./tools/pyflakes.sh"
- "./tools/weboob_lint.sh"
unittests:
stage: "test"
script:
- "./tools/run_tests.sh"
doc:
stage: "deploy"
script:
- "cd ./docs && make html"
test:2.7:
image: "python:2.7"
before_script:
- "pip install -r .ci/requirements.txt"
- "REQUIREMENTS=$(mktemp) && python setup.py requirements > ${REQUIREMENTS} && pip install -r ${REQUIREMENTS} && rm ${REQUIREMENTS}"
- "pip install -r .ci/requirements_modules.txt"
build:
stage: "build"
script:
- "./tools/local_install.sh ~/bin"
lint:
stage: "test"
script:
- "./tools/pyflakes.sh"
- "./tools/weboob_lint.sh"
unittests:
stage: "test"
script:
- "./tools/run_tests.sh"
doc:
stage: "deploy"
script:
- "cd ./docs && make html"
test:3:
image: "python:3"
before_script:
- "pip install -r .ci/requirements.txt"
- "REQUIREMENTS=$(mktemp) && python setup.py requirements > ${REQUIREMENTS} && pip install -r ${REQUIREMENTS} && rm ${REQUIREMENTS}"
- "pip install -r .ci/requirements_modules.txt"
build:
stage: "build"
script:
- "./tools/local_install.sh ~/bin"
lint:
stage: "test"
script:
- "./tools/pyflakes.sh"
- "./tools/weboob_lint.sh"
unittests:
stage: "test"
script:
- "./tools/run_tests.sh -3"
doc:
stage: "deploy"
script:
- "cd ./docs && make html"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment