Commit 01b52ef5 authored by Romain Bignon's avatar Romain Bignon

fix detection of python version and output

parent 5ab97c1f
......@@ -131,9 +131,8 @@ def install_weboob():
else:
requirements.append('PIL')
if sys.version_info.major == "2" and sys.version_info[1] < 6: # older than 2.6
print(sys.version_info)
print('Python older than 2.6 is not supported. %s'%sys.version_info, file=sys.stderr)
if sys.version_info < (2,6):
print('Python older than 2.6 is not supported.', file=sys.stderr)
sys.exit(1)
if not options.deps:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment